Um dia era pra mostrar coisas sobre o excel, hoje é para compartilhar meus poucos conhecimentos, com os interessados!

sexta-feira, 27 de maio de 2011

Programação Estruturada I - 2º Desafio - Etapa 1 - Passo 1





algoritmo "Alg_para_conversao_moedas"
// Função : Algoritmo que faz conversão monetaria.
// Autor :  Lucas Vinha Teixeira
// Data : 05/04/2011
// Seção de Declarações 
var
Moeda,Valor_converter,Cotacao,Valor_convertido:Real  // Variáveis de entrada do tipo real.
Nome_Moeda,Controle_saida:Caracter                   // Variáveis de entrada e saida do tipo caracter.
inicio
// Seção de Comandos 

Enquanto (Controle_saida <> "S") ou (Controle_saida <> "s") FACA // Laço para verificar se quer sair do programa ou não.

Escreval("*****************************************************************")
Escreval("*****************************************************************")
Escreval("***********Programa para conversão de moedas*********************")
Escreval("*********************Versão 1.0**********************************")
Escreval("***********************By LCS************************************")
Escreval("*****************************************************************")
Escreval("*****************************************************************")
Escreval

//PEQUENO MENU DE ESCOLHA DE MOEDAS.
Escreval("*********Menu******************")
Escreval("1 - Dolar *********************")
Escreval("2 - Euro  *********************")
Escreval("3 - Iene  *********************")
Escreval("4 - Outra *********************")
Escreval("*********Fim menu**************")
Escreval

// ESCOLHA DA MOEDA.
Escreva("Escolha o número da opção para conversão:")
Leia(Moeda)
Escreval

//EMTRADA DOS DADOS DE COTACAO E VALOR PARA CONVERSÃO.
Escreva("Escreva a cotação atual da moeda:")
Leia(Cotacao)
Escreva("Digite o valor em R$ para conversão:")
Leia(Valor_Converter)

Escreval

//_____________________________________________________________________________
//Inicio bloco condicional, aqui será verificado o tipo de moeda escolhida para
//que seja realizado o calculo especificado.
//_____________________________________________________________________________

Se Moeda = 1 Entao
Nome_moeda<- "U$$ Dolar"
Valor_convertido <- Valor_converter * Cotacao
FimSe

Se Moeda = 2 Entao
Nome_moeda<- "€ Euro"
Valor_convertido <- Valor_converter * Cotacao
FimSe

Se Moeda = 3 Entao
Nome_moeda<- "¥ Iene"
Valor_convertido <- Valor_converter * Cotacao
FimSe

Se Moeda = 4 Entao
Escreva("Digite o nome da moeda:")
Leia(Nova_moeda)
Valor_convertido <- Valor_converter * Cotacao
FimSe

//_____________________________________________________________________________
//                             FIM DO BLOCO CONDICIONAL
//_____________________________________________________________________________


//_____________________________________________________________________________
//INICIO DO BLOCO DE IMPRESSÃO DOS DADOS NA TELA,AQUI VAMOS APRESENTAR A MOEDA
//ESCOLHIDA,O VALOR DA COTAÇÃO E O VALOR CONVERTIDO NA MOEDA ESCOLHIDA.
//_____________________________________________________________________________

Escreval("Você converteu R$ para ",Nome_moeda)
Escreval("Cotação = ",Cotacao)
Escreval(" O valor em ",Nome_moeda," é: ",Valor_convertido)
Escreval
Escreval("Obrigado por usar nosso serviço de conversão monetária")

//_____________________________________________________________________________
//                             FIM DO BLOCO DE IMPRESSÃO
//_____________________________________________________________________________





Escreva("Deseja sair do programa? s ou n: ") // Entrada do valor para validação do laço de saída.
Leia(Controle_saida)
LimpaTela // Método para limpar a tela para um novo cálculo.

FimEnquanto

LimpaTela //Método para limpar a tela para finalizar o programa.

fimalgoritmo