quinta-feira, 26 de maio de 2011

VisualG - Comandos de Repetição - Para ... faça

Esta estrutura repete uma seqüência de comandos um determinado número de vezes.
para <variável> de <valor-inicial> ate <valor-limite> [passo]
faca
<incremento>

fimpara

Descrição
<variável >
É a variável contadora que controla o número de repetições do laço.
Na versão atual, deve ser necessariamente uma variável do tipo inteiro, como todas as expressões deste comando.
<valor-inicial>
É uma expressão que especifica o valor de inicialização da variável contadora antes da primeira repetição do laço.
<valor-limite >
É uma expressão que especifica o valor máximo que a variável contadora pode alcançar.
<incremento >
É opcional. Quando presente, precedida pela palavra passo, é uma expressão que especifica o incremento que será acrescentado à variável contadora em cada repetição do laço.
Quando esta opção não é utilizada, o valor padrão de <incremento> é 1. Vale a pena ter em conta que também é possível especificar valores negativos para <incremento>. Por outro lado, se a avaliação da expressão <incremento > resultar em valor nulo, a execução do algoritmo será interrompida, com a impressão de uma mensagem de erro.
fimpara
Indica o fim da seqüência de comandos a serem repetidos. Cada vez que o programa chega neste ponto, é acrescentado à variável contadora o valor de <incremento >, e comparado a <valorlimite>. Se for menor ou igual (ou maior ou igual, quando <incremento > for negativo), a seqüência de comandos será
executada mais uma vez; caso contrário, a execução prosseguirá a partir do primeiro comando que esteja após o fimpara.

são avaliados uma
<valor-inicial >, <valor-limite > e <incremento > únicaantes da execução da primeira repetição, e não se alteram durante a execução, mesmo que variáveis eventualmente presentes nessas expressões tenham
vez
do laço
seus valores alterados.
No exemplo a seguir, os números de 1 a 10 são exibidos em ordem crescente.
algoritmo "Números de 1 a 10"
var j: inteiro
inicio
para j de 1 ate 10 faca
escreva (j:3)
fimpara
fimalgoritmo
Importante:
que <valor-limite > (ou menor, quando <incremento> for negativo), o laço não será
executado nenhuma vez. O exemplo a seguir não imprime nada.
algoritmo "Numeros de 10 a 1 (não funciona)"
var j: inteiro
inicio
para j de 10 ate 1 faca
escreva (j:3)
fimpara
fimalgoritmo
Este outro exempo, no entanto, funcionará por causa do passo -1:
algoritmo "Numeros de 10 a 1 (este funciona)"
var j: inteiro
inicio
para j de 10 ate 1 passo -1 faca
escreva (j:3)
fimpara
fimalgoritmo
Se, logo no início da primeira repetição, <valor-inicial > for maior
<seqüência-de-comandos>



Download

0 comentários:

Postar um comentário